# unable to connect to specified database (snowflake)

**URL:** <https://discourse.getdbt.com/t/unable-to-connect-to-specified-database-snowflake/5643>\
**Category:** Help\
**Created:** [December 15, 2022, 3:18pm UTC](https://discourse.getdbt.com/t/unable-to-connect-to-specified-database-snowflake/5643 "2022-12-15T15:18:46Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![craig.jones](https://sea2.discourse-cdn.com/flex020/user_avatar/discourse.getdbt.com/craig.jones/32/1483_2.png) [@craig.jones](https://discourse.getdbt.com/u/craig.jones)\
**Post date:** [December 15, 2022, 3:18pm UTC](https://discourse.getdbt.com/t/unable-to-connect-to-specified-database-snowflake/5643/1 "2022-12-15T15:18:46Z")

</div>

Trying to setup dbt core to a snowflake db, fails everytime, if i use the same creds in dbt cloud all ok. Doing this on an M1 Mac

error is:

Connection test: [ERROR]

1 check failed:  
dbt was unable to connect to the specified database.  
The database returned the following error:

> Database Error  
> 250001: Could not connect to Snowflake backend after 0 attempt(s).Aborting

Check your database credentials and try again. For more information, visit:

> **[Connection profiles | dbt Developer Hub](https://docs.getdbt.com/docs/core/connect-data-platform/connection-profiles)**
>
> Configure your profile using the command line.

---

<div class="post-metadata">

**Author:** ![ted.conbeer](https://sea2.discourse-cdn.com/flex020/user_avatar/discourse.getdbt.com/ted.conbeer/32/42_2.png) [@ted.conbeer](https://discourse.getdbt.com/u/ted.conbeer)\
**Post date:** [December 15, 2022, 6:53pm UTC](https://discourse.getdbt.com/t/unable-to-connect-to-specified-database-snowflake/5643/2 "2022-12-15T18:53:42Z")

</div>

I think the issue is the `account` parameter in your profile. (I always get this wrong with snowflake…). dbt expects just the part of the url _before_ [snowflakecomputing.com](http://snowflakecomputing.com), like `abc1234` or `abc1234.us-east-1.aws`

See the docs: [Snowflake setup | dbt Developer Hub (getdbt.com)](https://docs.getdbt.com/reference/warehouse-setups/snowflake-setup#account)

---

<div class="post-metadata">

**Author:** ![Saikrishna](https://avatars.discourse-cdn.com/v4/letter/s/a9a28c/32.png) [@Saikrishna](https://discourse.getdbt.com/u/Saikrishna)\
**Post date:** [March 28, 2023, 3:04pm UTC](https://discourse.getdbt.com/t/unable-to-connect-to-specified-database-snowflake/5643/3 "2023-03-28T15:04:04Z")

</div>

In the account parameter there will be"." instead of “.” use “-”, as while copying the account ID it gets copied with “.”. I got the error resolved by doing this.

---

<div class="post-metadata">

**Author:** ![taylie](https://sea2.discourse-cdn.com/flex020/user_avatar/discourse.getdbt.com/taylie/32/2897_2.png) [@taylie](https://discourse.getdbt.com/u/taylie)\
**Post date:** [August 20, 2023, 1:29am UTC](https://discourse.getdbt.com/t/unable-to-connect-to-specified-database-snowflake/5643/4 "2023-08-20T01:29:46Z")

</div>

@craig.jones check this [table](https://docs.snowflake.com/en/user-guide/admin-account-identifier.html#non-vps-account-locator-formats-by-cloud-platform-and-region) for specific formatting as per your region.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex020/uploads/getdbt/original/1X/a7a7ca1fe379aaf90952b0e13118a817babcd14f.png) [@system](https://discourse.getdbt.com/u/system)\
**Post date:** [November 1, 2023, 8:20pm UTC](https://discourse.getdbt.com/t/unable-to-connect-to-specified-database-snowflake/5643/5 "2023-11-01T20:20:57Z")

</div>

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.
