Building model from seed fails when building parent models, eventhough there are none

The problem I’m having

I have a seed .csv that I’m building a model on. (norm)
When I run dbt build --select +MyModel it runs like a charm.
But when I run dbt build --select +MyModel+ eventhough there are no parent models, it will fail everytime.

Ever since we upgrade from dbt-sqlserver 1.0.0 to dbt-sqlserver 1.4.3 this problem has popped up. And I just can’t figure out what is causing it.

The context of why I’m trying to do this

I’m just trying to create models using seeds. This all worked fine before the update.

What I’ve already tried

Recreating the seed files with different names.
Recreating the models with different names.
Just doing SELECT * FROM Seedfile in the model

Some example code or error messages

('42000', "[42000] [Microsoft][ODBC Driver 17 for SQL Server][SQL Server]No item by the name of 'teun_kruijer_norm.test' could be found in the current database 'dwh-vlanalytics-dev', given that @itemtype was input as '(null)'. (15225) (SQLMoreResults)")
09:24:13    compiled Code at target\run\veko\models\norm\seed\test.sql

I can see dbt creates the model succesfully with the _dbt__temp exentsion, but somehow it doesn’t remove it when I run the dbt build --select +MyModel+ command and thus when it finishes it can find the model minus the _dbt__temp part.

Columns in seed model: credit_limit_info_v2.csv

Customer reference,
Credit limit status,
Credit limit amount,
Credit limit expiry date,
Request date,
Requested amount

Model query:
Select * FROM {{ref("credit_limit_info_v2")}}

Found a workaround by materializing the norm layer on the seed layer as tables instead of view. Not desirable, but necessary.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.