Cannot drop or create external tables since upgrade to dbt-1.5.0

The problem I’m having

I was using the command

dbt run-operation stage_external_sources --vars "ext_full_refresh: true"

to drop and create external tables defined in my sources.yml
However since upgrading to dbt-1.5.0 and redshift 1.5.1 - this no longer works and I get the following error

 DROP EXTERNAL TABLE cannot run inside a transaction block

It was working prior to the upgrade of dbt-core

The context of why I’m trying to do this

This was working with previous version of dbt. I am defining my source table in my sources.yml

What I’ve already tried

I have tried updating dbt_external_tables package

Some example code or error messages

Encountered an error while running operation: Database Error
  DROP EXTERNAL TABLE cannot run inside a transaction block

my sources.yml looks like this

  - name: dwh
    description: '{{ doc("source_desc") }}'
    database: my_db
    schema: my_schema
      - name: my_table
        description: my_desc
          location: my_s3_location
          file_format: parquet
          - name: some_col
            data_type: varchar(64)

If this is no longer supported can you show me an alternative way of doing this

i have just found out that this is related to the following bug - [ADAP-504] [Regression] cannot run inside a transaction block · Issue #425 · dbt-labs/dbt-redshift · GitHub