dbt build full refresh from CLI, but doesn't work in scheduled jobs

The problem I’m having: when I run dbt build --full-refresh in the dbt CLI for our models, it successfully recreates the tables in our postgres DB. i verify this by going to our postgres DB and querying the recreated table to see new rows added. however, when i set this up as a scheduled job using dbt’s scheduled job functionality with the same command, after the job shows that it’s successfully run, when i check our postgres DB tables, i’m not seeing any new rows added.

Any ideas how to debug/understand why the command works from the CLI (when i say works, i mean that im able to verify that the tables were indeed dropped and recreated via full-refresh), but not as a scheduled job?

What I’ve already tried: playing with variations like dbt build, dbt run, dbt run --full-refresh, dbt build full-refresh. Nothing seems to work

Hello glencoco, was this issue ever resolved? I am having the same problem with dbt run --full_refresh --select, I am sometimes even losing rows.