dbt cloud: cannot edit read-only editor

Just singed up for the first time on dbt cloud and I’m trying to work on a project, there is one issue with permission that I have no idea what wrong!!

Cannot edit on my dbt cloud editor, I tried few options but have no idea why is not letting me edit.

I tried to edit my “user” under “account settings”, which is a developer with these roles: “owner”, “member”, “everyone”. I tried to edit user details, but the button is disabled!

Anyone has any idea?

Thank you in advance.

Same here. I have an old project I hadn’t visited for a few months and now it is stuck in read only mode. I alos need help with tis issue. I am the only user on this account and project.

If you are on the main branch, you will need to create a new branch before being able to edit your project. dbt cloud doesn’t let you edit code on the main branch to encourage good branching hygiene

My github integration had been revoked so I was not able to check in changes and create a new branch. I started a new account with a new repository and now I am able to work. Thanks.

1 Like