dbt run Error: Unable to Load dbt_cloud.yml

The problem I’m having

I’m facing an issue with dbt on my VSCode terminal. I have a conda environment with dbt loaded. When I initialize the jaffle_shop project and try to execute commands like dbt run or dbt seed, I encounter the following error:

error loading configuration: could not open dbt_cloud.yml for reading: `open C:\Users\Tyson\.dbt\dbt_cloud.yml: The system cannot find the file specified.`

I’m not sure why dbt is attempting to read from dbt_cloud.yml when I’m using dbt core. I’ve checked the specified directory, and the dbt_cloud.yml file doesn’t exist.

Has anyone faced a similar issue or can provide guidance on how to resolve this error?

Thank you in advance for your assistance!

The context of why I’m trying to do this

Just trying to run the project and learn more about working with dbt on my own machine.
Everything has been straightforward up until this error.

What I’ve already tried

I’ve tried adding a dbt_cloud.yml file that looks like

project-id: 1234567

but I then receive more errors asking for more information I do not have.

How did you install dbt? Is there a chance you did
pip install dbt
and not
pip install dbt-[adapter name]

Note: @Josh Devlin (he) originally posted this reply in Slack. It might not have transferred perfectly.

1 Like

Thank you for your reply,

I installed dbt through

pip install dbt-core

I also tried uninstalling and reinstalling and am still getting the same error.

What does pip freeze | grep dbt give you?

Note: @Josh Devlin (he) originally posted this reply in Slack. It might not have transferred perfectly.

<@U014KQZRLF5> I’m having the same issue running dbt locally and also installed dbt-core in a new venv

Note: @Dstorms101 originally posted this reply in Slack. It might not have transferred perfectly.

When you run which dbt and where dbt, what are the outputs?

It seems the dbt your machine is trying to use is the dbt-cloud-cli and not dbt-core. We just have to understand why

1 Like

I’m having this same issue as well. running which and where are in the same location, and running pip freeze | grep dbt brings back this


What is the location it returns when you run which dbt or where dbt?

…venv\Scripts\dbt and …venv\Scripts\dbt.exe

It seems your system is trying to run the dbt-cloud-cli, which is the lib that is searching for the cloud.yml

Try to solve this issue following the official instructions below:

If you already have dbt Core installed, the dbt Cloud CLI may conflict. Here are some considerations:

  • Reverting back to dbt Core from the dbt Cloud CLI
    If you’ve already installed the dbt Cloud CLI and need to switch back to dbt Core:

    • Uninstall the dbt Cloud CLI using the command: pip uninstall dbt
    • Reinstall dbt Core using the following command, replacing “adapter_name” with the appropriate adapter name:
pip install dbt-adapter_name --force-reinstall

For example, if I used Snowflake as an adapter, I would run: pip install dbt-snowflake --force-reinstall

updating dbt-core==1.6.8 to 1.7.1 fixed the issue

1 Like