Webhook returns Failure status 'missing request body'

The problem

My webhook, which calls an HTTP triggered Azure function (written in Python), suddenly stopped working with Failure as run status. When checking the run history, the following information is given:

During the development process, whenever an error occurred, the run status always read Error - not Failure as it does now.


The webhook is triggered on Run Completed events, and has been working perfectly fine the last two days. Testing the endpoint of the webhook returns Success, and from that I conclude that there is nothing wrong with the code in the function that receives the webhook.

The webhook is created to write logs from finished dbt jobs into Snowflake, through the python snowflake-connector. If there are any other ways of achieving this, I am all ears. However, it would be nice to come to the bottom of this, somewhat mysterious, error.

What I’ve tried

  • Verified that the URL for the function is correct
  • Checked the endpoint connection in the dbt UI
  • Simplified my code to double check that the python code is not the problem
  • Tried making a new webhook

I have run out of ideas as to why this failure is happening, and all feedback is very much appreciated.

Thanks in advance!

Hey @marialinea! Thanks for the robust writeup describing what you’ve tried so far.

If you send a message with these same details to support@getdbt.com, they’ll be able to have a look at the logs and should be able to give you some more targeted advice.