Completing the Project Wizard

I am a complete dbt newbie. I’m guessing that the process for creating a new project is as follows. Please correct or add anything I got wrong or missed:

  1. Create a Snowflake account, login, create a sample database, create a table, and fill it with sample data. Note the account credentials for later use.
  2. Note the special Snowflake connection parameter, for later use.
  3. Create a dbt account
  4. In the project creation wizard, put the connection parameter you noted in step 2 into the Account textbox.
  5. put the name of the database you created in Snowflake in the database textbox.
  6. put the word ‘Snowflake’ in the warehouse textbox.
  7. put ACCOUNTADMIN in the role textbox
  8. use the Snowflake credentials you created in step 1 in the Development Credentials Username and Password textboxes.
  9. Click the ‘Test Connection’ button.

Hello @pudnik26354 , welcome to the dbt community!

Overall, see this link first.

Specific notes on your steps:

It should be in the form of: for example or

the warehouse is not “Snowflake”, it is the name of the Virtual Warehouse within snowflake.

You can, but I would use a different role. See here and here

Ok, but there are TWO ‘warehouse’ textboxes on the new project form. The first one appears under the pick-the-vendor area, and the second one appears in the snowflake account area.

In snowflake, if one clicks on the area in the lower lefthand corner to the right of the snowflake icon, one can get all the info needed to properly format the ‘Account’ parameter for the dbt new project form. That I get.

But what does one put in the first ‘warehouse’ textbox?

Thanx for your help,


The first Warehouse text box should be greyed out since you have already selected “Snowflake” in step 1.

Let’s try with some screenshots:


…I think it worked! so now I just need a sample dbt script/model that will run a simple query on the default sample Snowflake database…

The little issue is for the ones using snowflake trail … in the new ui, there no partner connect item in the menu as reported in the image in the guide… but it works using a more manual entry as above

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.