DBT cloud commands stuck when setting variables

The problem I’m having

When running any dbt command in dbt cloud specifying variables the run gets stuck and no output is shown.

The context of why I’m trying to do this

I’m trying to modify project variables from the CLI

Some example code or error messages

If I run dbt run the process completes without any errors. But if I run dbt run --vars '{development_row_limit: 1000}' then the logs show

Unable to do partial parsing because config vars, config profile, or config target have changed

and the commands gets stuck on “running”, no further logs are shown (even though all models should have been built).

Running dbt run --vars '{development_row_limit: 1000}' then canceling and running the same command again fixes the issue.

This can also be fixed by running
dbt parse --vars '{development_row_limit: 1000}'
and then dbt run --vars '{development_row_limit: 1000}' but any further changes in the value of the variable will prevent partial parsing and the command will be stuck again