Error in installing the ad_reporting package

I’m trying to install the ad_reporting package, but I’m encountering an error, as shown in the screenshot below. I’m unsure about what I might be doing wrong. Can anyone provide guidance or assistance in resolving this issue?

Entering this to install the package -

  • package: fivetran/ad_reporting
    version: 1.7.0

hey there! could you share a screenshot of your packages.yml file from this branch? just want to confirm that the config is correct there

also i see that you’re using a release candidate version of dbt – i wonder if this problem would persist if you downgraded to the latest official version, dbt 1.6.6 :thinking:

1 Like

I wonder if you forgot to save the packages.yml file? I can’t remember offhand whether dbt cloud makes sure your file is saved or not

Hey, tried it with 1.6.6 and that didn’t work either. Showed the exact same thing in error except for Running with dbt=1.6.6

Hey, I did save the packages.yml file before running dbt deps to install the package

Ahh the screenshot explains it! Your packages.yml file should be at the root of your project, in the same place as your dbt_project.yml file - not inside the dbt_packages directory.


Thank you so much, didn’t realize I was making such an obvious mistake :sweat_smile:. While it installed the package its showing an error at the top right in the server log. Is that something I should be worried about?

1 Like

There will probably be an error until the packages have all installed - once it’s finished can you click into the error and see what it is?

Hello, so I’ve been working on this and there’s a compilation error

Compilation Error
Model ‘model.ad_reporting.ad_reporting__ad_group_report’ (models/ad_reporting__ad_group_report.sql) depends on a node named ‘int_ad_reporting__ad_group_report’ which was not found

As shown in the attached screenshot, there appears to be a naming discrepancy in our models. Specifically, the model model.ad_reporting.ad_reporting__ad_group_report seems to depend on a node named int_ad_reporting__ad_group_report, which isn’t found.

I’ve noticed that some of the models and files have a double underscore (__) naming convention rather than a single underscore (_). I’m currently going through the files manually to fix this discrepancy for the Google Ads related models.

However, my concern is that this issue might not be isolated to just the Google Ads models. If this double underscore naming convention has been used across other sources, I may encounter similar errors in the future.

I’d like to understand: Why was the double underscore (__) convention used? Is there a specific reason or requirement behind this and I would appreciate any help in fixing this error

we use the double underscore after the name of the package/source (so in this case, after ad_reporting). otherwise we use the single underscore

however, i don’t think the issue here is around mismatched names – does this error come up when you dbt run or just when you dbt compile? i think i’ve seen this sort of error before and will do some digging

I deleted this package and installed just the google ads package and that error was solved. However, I am facing a different issue now. I am unable to preview any models. Some show preview errors preview or come up blank. Another model showed an unclosed string literal error but I went through the code and it was fine. I am looking through the projects.yml file and also the staging models currently to find any errors there but I was wondering if I am supposed to do something else or if I am missing out on something crucial.

This says that there is a problem at line 5, character 13 of your query. This will be different than the lines of code in the IDE, so you should try clicking Compile and reviewing that version of the code (which will resolve ref’s etc).

the second last screenshot I shared is off the compile result, it just shows an empty box next to 1. So, I am still not sure about what I am doing wrong

@fouzia_riaz and I hopped on a call and determined the cause of the above issue to be a dbt cloud limitation, specifically that you can’t preview a model from a package in cloud – is there anything on the roadmap to change that?

1 Like

Thanks for the call yesterday. I successfully used the command that you had pasted in the chat for the google_ads__account_report model as reviewed in our meeting

However, I encountered an issue when I attempted to apply the same command structure to another model in my project, google_ads__ad_group_report. Specifically, I used dbt build --select google_ads__ad_group_report, but this did not yield the expected result.

I’m currently unable to access the Google Meet chat history where you had originally pasted the command, so I can’t cross-reference it. Could you please confirm if the syntax I’m using is correct?

I have added screenshots for the snippet of what the end of the error in the logs looks like and the overall system logs. Any additional guidance or steps I might be missing would be greatly appreciated.