I’m encountering an issue with my dbt project while trying to run the command
dbt deps. The specific error message I’m receiving is as follows:
Version error for package dbt-labs/dbt_utils: Could not find a satisfactory version from options: ['<0.9.0', '>=0.9.0', '<2.0.0', '>=0.8.1', '<0.9.0']
I’m currently working on a project that involves using dbt for data transformation and modeling. As part of this process, I need to manage package dependencies using the
dbt deps command to ensure that the required packages are installed correctly. However, I’ve encountered this version-related error, which is preventing me from proceeding with the dependency installation.
I’ve attempted a few troubleshooting steps to resolve this issue:
Checking Package Versions: I reviewed the versions of the
dbt-labs/dbt_utilspackage to ensure they align with the specified options in the error message. Unfortunately, none of the listed versions seem to satisfy the requirement.
Updating dbt: I checked my dbt version and found that I’m using
1.6.0. To see if updating dbt would resolve the issue, I considered upgrading to a more recent version. However, I’m concerned about potential compatibility issues with the rest of the project.
Here’s an example of the code I’m using and the error message I’m encountering:
$ dbt deps Running with dbt=1.6.0 Encountered an error: Version error for package dbt-labs/dbt_utils: Could not find a satisfactory version from options: ['<0.9.0', '>=0.9.0', '<2.0.0', '>=0.8.1', '<0.9.0']
I’m uncertain about how to proceed to overcome this version error and successfully manage my package dependencies in dbt.