I'm trying to install packages from packages.yml using dbt deps and encountering an issue in Mac with SSL cert

The problem I’m having

When I try to run dbt deps command in terminal I’m encountering the following issue
Encountered an error:
External connection exception occurred: HTTPSConnectionPool(host=‘hub.getdbt.com’, port=443): Max retries exceeded with url: /api/v1/index.json (Caused by SSLError(SSLCertVerificationError(1, ‘[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:1129)’)))

The context of why I’m trying to do this

I’m trying to install packages for generating the schema

  • package: dbt-labs/codegen
    version: 0.12.1

  • package: dbt-labs/dbt_utils
    version: 1.1.1

What I’ve already tried

I have tried to upgrade the software, Upgrade certifi, pip install python-certifi-win32 but these din’t work.

I’m currently using dbt 1.4.6 version

Some example code or error messages

Put code inside backticks
  to preserve indentation
    which is especially important 
      for Python and YAML! 

Does the discussion in this dbt issue help? https://github.com/dbt-labs/dbt-core/issues/7153

Note: @quazi.irfan originally posted this reply in Slack. It might not have transferred perfectly.

I have tried different things from the discussion but that din’t help.