Model and column description not populating on docs serve

Model and column description not populating on docs serve

I’ve built a model in the marts folder and added the description of the model and each of its column. When i do a dbt docs serve --port 9999 , and view it on the cloud, I dont see the description and even the test sections get populated.

I’ve tried rebuilding the yml and even downgrading from 1.6 to 1.5. I’ve added and remove double quotes on the description and still doesnt work

Some example code or error messages

version: 2

    description: "This table is inclusive of all of the order data from stripe and includes descriptive fields for the items purchased, such as product names as well as user information like Stripe IDs, etc"
        - name: ORDER_ID
          description: "The primary key for all rows in the order table in RDS, each row has a distinct value"
            - not_null
            - unique
        - name: ORDER_GUID
          description: "This a long character string that comes from Stripe and should be unique for each purchase event."
            - not_null
            - unique

One step I have observed missing in your post is the dbt docs generate.
On every yaml change, we need to re-run that step, so that catalog.json is updated which is used by the web server to show the documentation.

One off topic suggestion, please don’t use so much bold font, like capitals it feels like being shouted at.

@stephen ahhh sorry i forgot about the formatting on the post.

The commands i ran as follows:

  1. dbt docs generate
  2. dbt docs serve --port 999

After running #1 , the catalog.json was generated inside the target folder. When I run #2 I still get the no description

I find it weird that the case of the column name is not matching the case in your yaml files(they usually match in my experience) . Are you sure the yaml file is being picked up all ?

Any idea which directory have you placed your yaml files under ?

It needs to be within the `models/(schema)/schema_models.yml` directory. Maybe it may work even within the "models" directory, but it can't be in the base directory which has the dbt_project.yml.

@stephen Below is my folder structure. Im in dbt slack channel too if you want to do a quick huddle