New user trying dbt. Building Customres model and Getting Error 'The project raw has not enabled BigQuery'

The problem I’m having

Building Customres model and Getting Error ‘The project raw has not enabled BigQuery’

Log file

21:10:57 Timing info for model.my_new_project.customers (execute): 21:10:56.259640 => 21:10:57.983468
21:10:57 Database Error in model customers (models/customers.sql)
The project raw has not enabled BigQuery.
compiled Code at target/run/my_new_project/models/customers.sql
21:10:57 1 of 3 ERROR creating sql view model dbt_rindiketiya.customers … [ERROR in 1.76s]
21:10:57 Finished running node model.my_new_project.customers

The context of why I’m trying to do this

What I’ve already tried

Some example code or error messages

Put code inside backticks
  to preserve indentation
    which is especially important 
      for Python and YAML! 

I ran into the same problem tonight when I was doing the BigQuery Quickstart. It looks like dbt is querying a “raw” project that doesn’t exist in Google Cloud…? Here is one workaround:

On Step 8, “Build your first model”, change the following two lines that go into your customers.sql file:

  1. On line 8
    from raw.jaffle_shop.customers
    to
    from `dbt-tutorial`.jaffle_shop.customers

  2. On line 20
    from raw.jaffle_shop.orders
    to
    from `dbt-tutorial`.jaffle_shop.orders

This will have the queries go to the dbt sample datasets publicly available in BigQuery.

The errors are popping up due to a commit in the tutorial made last week in response to a customer error report. It looks like it may have introduced a new issue.

1 Like

Additional follow-up: that block of code was moved out of the BigQuery Quickstart file to a “snippets” folder in the repo three weeks ago. From there it is now copied with an import statement into the Quickstart guides for BigQuery, Redshift, Databricks, Snowflake, Fabric, and Starburst Galaxy.

It looks like raw.jaffle_shop.customers is for Snowflake and not BigQuery. Other Quickstart tutorials are likely broken right now too, since the route to the sample data is different for every engine. The BigQuery version of the code was copied in for a while. Then someone reached out to support about the Snowflake Quickstart being broken, they fixed it, …and then it broke for BigQuery since they are all connected now. :upside_down_face:

I think this commit should probably be rolled back:

1 Like

Hey everyone, thanks for flagging this issue and you’re absolutely right – it’s due to my pr update. apologies about that and I’ll get this fixed asap to ensure there’s no confusion. many thanks for all the help :pray: !

as an update, here’s the PR that should revert this. thank you again and we’ll hopefully get this fixed today!

update - the fix is now live: Quickstart for dbt Cloud and BigQuery | dbt Developer Hub

Many thanks for the super-fast fix! Appreciate your help.
~Craig

1 Like

No worries, thanks so much for raising this!