Probelms with using jsonb columns as inputs in dbt native unit_test functionality

The problem I’m having

For one unit_test using the following format the unit_test framework works as expected.

- name: test_a_grading
  model: intermediate_model
    - input: ref('staging model')
        - {  faults: '["Some Unmapped Fault"]' }
        - { faults: '["Untested","Mapped Fault"]' }
        - { faults: '["Some Unmapped Fault"]', mapped_hardware_grade: Unmapped, mapped_software_grade: Unmapped }
        - { faults: '["Untested","Mapped Fault"]', mapped_hardware_grade: Untested, mapped_software_grade: Pass }

But other unit_tests in the same yaml file using the same exact format that also accept a jsonb column called faults.

The context of why I’m trying to do this

Im trying to use the dbt native unit_test functionality on my SQL models to test if a particular macro im using to turn input_column (jsonb) → output_column (text)

What I’ve already tried

Ive tried embedding JSONB objects using the > or | operators as well, as seen here Include JSON object in YAML - TheTrendyCoder

Some example code or error messages

Here is a sample error message in the other test in the same yaml file. I have no idea why there are double “” around the elements in the json.