Set schema/dataset for BigQuery

The problem I’m having

The schema that I have set in dbt_project.yml does not take effect in my production environment when using dbt cloud.

The context of why I’m trying to do this

Im running a project in dbt cloud and using Google BigQuery. I just tried to add a specified schema in the dbt_project.yml and when Im developing and building I get the corresponding schemas as datasets in BigQuery. But when I merge in to master and the CI build runs it does not create the corresponding datasets.

What I’ve already tried

Some example code or error messages

Here are the relevant config from dbt_project.yml:

models:
  provet_hammaro:
    +materialized: view
    +database: provet-hammaro

    staging:
      +schema: staging
      +materialized: view

    marts:
      +schema: marts
      +materialized: table 

In BiQuery I have the following datasets:

  • dbt_mlarsson
  • dbt_mlarsson_staging
  • dbt_mlarsson_marts
  • provet_hammaro

I expected to have these datasets as well:

  • provet_hammaro_staging
  • provet_hammaro_marts

Has anyone seen this?

Is everybody on vacation or am I not being clear enough? Is there a guide or examples on how schemas work when running in BigQuery?