unable to get dbt working on a new venv

The problem I’m having

I created a new virtual environment and installed dbt-mysql (pip install dbt-mysql). I am using python3.11
When I enter “dbt” I get the below error. Afterwhich I installed dbt-core (pip install dbt-core). But that did not work either. I keep getting the same error.

The context of why I’m trying to do this

What I’ve already tried

Some example code or error messages

(python311) C:\projects\dbt\python311\Scripts>dbt
Traceback (most recent call last):
  File "<frozen runpy>", line 198, in _run_module_as_main
  File "<frozen runpy>", line 88, in _run_code
  File "C:\projects\dbt\python311\Scripts\dbt.exe\__main__.py", line 4, in <module>
  File "C:\projects\dbt\python311\Lib\site-packages\dbt\main.py", line 2, in <module>
    from dbt.logger import GLOBAL_LOGGER as logger, log_cache_events, log_manager
  File "C:\projects\dbt\python311\Lib\site-packages\dbt\logger.py", line 16, in <module>
    from dbt.dataclass_schema import dbtClassMixin
  File "C:\projects\dbt\python311\Lib\site-packages\dbt\dataclass_schema.py", line 13, in <module>
    from mashumaro import DataClassDictMixin
  File "C:\projects\dbt\python311\Lib\site-packages\mashumaro\__init__.py", line 4, in <module>
    from mashumaro.serializer.json import DataClassJSONMixin
  File "C:\projects\dbt\python311\Lib\site-packages\mashumaro\serializer\json.py", line 28, in <module>
    class DataClassJSONMixin(DataClassDictMixin):
  File "C:\projects\dbt\python311\Lib\site-packages\mashumaro\serializer\base\dict.py", line 21, in __init_subclass__
    raise exc
  File "C:\projects\dbt\python311\Lib\site-packages\mashumaro\serializer\base\dict.py", line 17, in __init_subclass__
  File "C:\projects\dbt\python311\Lib\site-packages\mashumaro\serializer\base\metaprogramming.py", line 365, in add_to_dict
    pre_serialize = self.get_declared_hook(__PRE_SERIALIZE__)
  File "C:\projects\dbt\python311\Lib\site-packages\mashumaro\serializer\base\metaprogramming.py", line 203, in get_declared_hook
    if type_name(cls) != DataClassDictMixinPath:
  File "C:\projects\dbt\python311\Lib\site-packages\mashumaro\meta\helpers.py", line 28, in type_name
    if is_generic(t):
  File "C:\projects\dbt\python311\Lib\site-packages\mashumaro\meta\helpers.py", line 54, in is_generic
    raise NotImplementedError

what is the version of your dbt-mysql?

You could try using the latest alpha versions

CleanShot 2024-04-01 at 23.55.22@2x