I was reading about
require-dbt-version | dbt Developer Hub (getdbt.com)
as I am trying v1.2 to upgrade from v1.0 ( we have been using so far in our jobs)
Should I add this in my yml?
require-dbt-version: [">=1.2.0", "<1.3.0"]
as I don’t want to use 1.3 yet … is this the right way?
or it does not matter as I am using dbt cloud?
You will need to manually select an upgraded minor version (i.e. the 3 in 1.3) in your dbt Cloud environment, so you don’t need to set
And even if you did, set the required version, it doesn’t work the way you described above –
require-dbt-version is only enforced when dbt is invoked and the dbt Cloud environment configuration UI (as well as dbt Core itself, if you install from the CLI) doesn’t take it into account.
In short: It’s a way to do a last-minute check that your environment is correctly configured, but isn’t used to create the configuration itself.
This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.