Cannot disable debug mode

Somehow I’ve got stuck with debug mode on, and I can’t seem to switch it off, I keep getting output like;

dbt debug
20:30:07  Running with dbt=1.4.5
INFO:stdout_log:20:30:07  Running with dbt=1.4.5

============================== 2023-03-13 20:30:07.286430 | 9bf66394-948e-4e19-adbd-162eaafb697b ==============================
20:30:07.286430 [info ] [MainThread]: Running with dbt=1.4.5
DEBUG:file_log:20:30:07.289374 [debug] [MainThread]: running dbt with arguments {'write_json': True, 'use_colors': True, 'printer_width': 80, 'version_check': True, 'partial_parse': True, 'static_parser': True, 'profiles_dir': '/home/najmead/.dbt', 'send_anonymous_usage_stats': True, 'quiet': False, 'no_print': False, 'cache_selected_only': False, 'config_dir': False, 'which': 'debug', 'indirect_selection': 'eager'}
DEBUG:file_log:20:30:07.289831 [debug] [MainThread]: Tracking: tracking
DEBUG:file_log:20:30:07.295986 [debug] [MainThread]: Sending event: {'category': 'dbt', 'action': 'invocation', 'label': 'start', 'context': [<snowplow_tracker.self_describing_json.SelfDescribingJson object at 0x7f56461ca3a0>, <snowplow_tracker.self_describing_json.SelfDescribingJson object at 0x7f56461ca250>, <snowplow_tracker.self_describing_json.SelfDescribingJson object at 0x7f56461cafd0>]}
dbt version: 1.4.5
python version: 3.9.2
python path: /usr/bin/python3
os info: Linux-5.10.0-20-amd64-x86_64-with-glibc2.31

I’ve checked profiles.xml and dbt_project.xml, and can’t see any particular settings I’ve switched on. I’ve even tried to init an entirely new project, and still get the same result.

I saw this post with a similar issue, but their resolution was related to VS Code – I’ve tried running both from within and outside VS Code and I’m getting the same result.

What have I done???

I have the same issue and I’ve tried to google, but at last I found the answer through chat GPT my best developer mentor :slight_smile:

In powershell: Set-Item -Path Env:DBT_LOG_LEVEL -Value “info”

In cmd: export DBT_LOG_LEVEL=debug

in dbt: dbt --log-level none compile

chat GPT is really strange. Yesterday it was “sure” I could add a command in dbt_project.yml, but that didn’t work so today I asked again and provided the error and it said “I’m sorry…” Strange.

But the solution works!