I wanted to add some unit testing for my dbt models and then I got to know about the DATAMOCKTOOL package. It was great for my requirements and what I wanted to do. I have tested it in my local setup and it was working fine.

This is the package and version which I’m using –

  • package: mjirv/dbt_datamocktool
    version: [ “>=0.3.0” ]

But when I tried it in my project where dbt version which is installed is 1.2.6. I got an error -
Runtime Error
Failed to read package: Runtime Error
This version of dbt is not supported with the ‘dbt_datamocktool’ package.
The installed version of dbt: =1.2.6
Required version of dbt for ‘dbt_datamocktool’: [‘>=1.3.0’]

How can I know for this version of dbt which version of the DATAMOCKTOOL package is compatible? I’ve tried looking into docs but couldn’t find it.
Any help is appreciated.

@satyamj933 dbt-datamocktool >=0.2.1 requires dbt:>=1.3.0
you can use dbt-datamocktool== 0.2.0 as it requires dbt: >=0.19.2

1 Like

Thanks buddy!!! It works.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.