initial dbt setup error

The problem I’m having

Have existing dbt setup with version 1.2. Trying to setup a new cluster with latest 1.7 using same config info

ccs_developer@ccs-dbt-VM-linux-dev-vnet:~/.dbt$ dbt debug --project-dir /home/xxx_developer/dbtprojects --target dev
15:11:46 Running with dbt=1.7.10
15:11:46 dbt version: 1.7.10
15:11:46 python version: 3.8.10
15:11:46 python path: /usr/bin/python3
15:11:46 os info: Linux-5.15.0-1031-azure-x86_64-with-glibc2.29
15:11:47 Using profiles dir at /home/xxx_developer/.dbt
15:11:47 Using profiles.yml file at /home/xxx_developer/.dbt/profiles.yml
15:11:47 Using dbt_project.yml file at /home/xxx_developer/dbtprojects/dbt_project.yml
15:11:47 adapter type: databricks
15:11:47 adapter version: 1.7.9
15:11:47 Configuration:
15:11:47 profiles.yml file [OK found and valid]
15:11:47 dbt_project.yml file [OK found and valid]
15:11:47 Required dependencies:
15:11:47 - git [OK found]

15:11:47 Connection:
15:11:47 host:
15:11:47 http_path: sql/protocolv1/o/xxx/xxx
15:11:47 catalog: hive_metastore
15:11:47 schema: dbo
15:11:47 Registered adapter: databricks=1.7.9
15:11:48 Connection test: [ERROR]

15:11:48 1 check failed:
15:11:48 dbt was unable to connect to the specified database.
The database returned the following error:

Runtime Error
Database Error
‘HTTPResponse’ object has no attribute ‘drain_conn’

Check your database credentials and try again. For more information, visit:

The context of why I’m trying to do this

What I’ve already tried

Already tried getting a new pat key

Some example code or error messages

Runtime Error
Database Error
‘HTTPResponse’ object has no attribute ‘drain_conn’

I installed with venv and it worked. I had been trying to install into a user’s local packages and had different versions. Needed to do this:

pip install dbt-core
pip install dbt-databricks
pip install jsonschema==4.21.1
pip install testresources
pip install zipp==3.18.1
pip install requests==2.31.0
pip install urllib3==1.26.18